You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Jlivengood (Oct 20th 2012, 2:01am)

3 594

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by GregM (Mar 17th 2011, 9:20am)

23 3,604

by mrfixit

(Nov 1st 2012, 9:39pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 825

by dgaines

(Nov 10th 2012, 4:15pm)

by rockypoint (Nov 26th 2012, 6:02pm)

2 600

by mrfixit

(Nov 26th 2012, 7:30pm)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 442

by Wet_Boots

(Dec 26th 2012, 8:32am)

by Terri (Jan 9th 2013, 6:46am)

1 359

by Wet_Boots

(Jan 9th 2013, 11:08am)

by Marvel (Jan 19th 2013, 6:54am)

7 1,061

by Marvel

(Jan 22nd 2013, 7:49pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 352

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 478

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 687

by Trabecca

(Mar 18th 2013, 8:23am)

Show

Statistics:

458 Threads - 1,703 Posts (average 0.37 Posts per Day)