You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 0303maz (Jun 12th 2012, 9:20am)

1 146

by mrfixit

(Jun 12th 2012, 9:45am)

by clm716 (Aug 7th 2011, 9:58am)

1 146

by Central Irrigation

(Aug 7th 2011, 10:49am)

by Tee Jay (May 17th 2007, 8:38am)

3 146

by Bill Painter

(May 21st 2007, 1:12pm)

by lalloo (Aug 5th 2012, 11:02am)

2 144

by GatorGuy

(Aug 6th 2012, 9:13am)

by alf51175 (Aug 1st 2011, 9:53pm)

3 143

by alf51175

(Aug 2nd 2011, 8:02pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 143

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by julieblades (Jan 7th 2006, 6:27am)

6 141

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 137

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 135

by Scott76

(May 2nd 2013, 2:06pm)

by rickesco (Jul 28th 2004, 8:13am)

3 135

by aquamatic

(Jul 29th 2004, 10:36am)

Show

Statistics:

421 Threads - 1,568 Posts (average 0.35 Posts per Day)