You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by RT (Oct 12th 2011, 8:10pm)

1 855

by mrfixit

(Oct 12th 2011, 11:29pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 855

by Wet_Boots

(Jun 9th 2011, 10:09am)

by ruchuck (May 29th 2013, 8:54am)

7 868

by mrfixit

(Jun 2nd 2013, 12:03am)

by patk (Sep 18th 2011, 2:17pm)

2 869

by patk

(Sep 18th 2011, 3:41pm)

by ncampbel (Jul 1st 2011, 2:15pm)

1 880

by Mitchgo

(Jul 1st 2011, 9:20pm)

by jwdawgs (Feb 26th 2007, 4:10pm)

11 881

by Tom

(Feb 28th 2007, 12:48pm)

by shakeum (Sep 19th 2010, 8:50pm)

5 883

by Wet_Boots

(Sep 25th 2010, 7:21am)

by Fapp (Feb 21st 2005, 10:11am)

3 884

by nestors

(Apr 7th 2005, 8:51am)

by betsycam (Oct 13th 2013, 4:26pm)

1 888

by Wet_Boots

(Oct 14th 2013, 10:18am)

by stillc (Jul 29th 2009, 12:36pm)

2 892

by Wet_Boots

(Aug 4th 2009, 1:08am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)