You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by guy_sparky (Aug 12th 2010, 10:35am)

3 834

by mrfixit

(Aug 12th 2010, 5:12pm)

by PintoDr (Jun 28th 2012, 11:50pm)

5 838

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 842

by mrfixit

(Nov 10th 2011, 4:23am)

by mdige (Oct 31st 2011, 4:31pm)

1 848

by Wet_Boots

(Nov 1st 2011, 6:36am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 849

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 850

by Wet_Boots

(Aug 10th 2011, 7:51am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 871

by ddeferra

(Jun 8th 2011, 6:29pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 887

by Trabecca

(Mar 18th 2013, 8:23am)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 906

by jmduke7

(Aug 17th 2006, 3:13pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 915

by hi.todd

(Aug 10th 2010, 11:57am)

Show

Statistics:

462 Threads - 1,748 Posts (average 0.36 Posts per Day)