You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ncampbel (Jul 1st 2011, 2:15pm)

1 702

by Mitchgo

(Jul 1st 2011, 9:20pm)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 707

by mrfixit

(Jul 22nd 2008, 9:30pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 711

by Wet_Boots

(Aug 10th 2011, 7:51am)

by redlinr (Jun 9th 2005, 3:46am)

3 711

by Jazzer K

(Sep 2nd 2005, 6:14pm)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 738

by mrfixit

(Jun 10th 2012, 8:13pm)

by stillc (Jul 29th 2009, 12:36pm)

2 741

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 745

by Wet_Boots

(Jul 13th 2011, 11:30am)

by John199 (Aug 14th 2011, 3:57pm)

4 747

by hi.todd

(Aug 15th 2011, 7:29pm)

by kenttab (May 21st 2012, 5:51pm)

1 784

by mrfixit

(May 21st 2012, 8:58pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 807

by jmduke7

(Aug 17th 2006, 3:13pm)

Show

Statistics:

462 Threads - 1,707 Posts (average 0.37 Posts per Day)