You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 281

No reply

by clm716 (Aug 7th 2011, 9:58am)

1 279

by Central Irrigation

(Aug 7th 2011, 10:49am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 277

by jmduke7

(Aug 16th 2006, 6:36pm)

by rose (Sep 11th 2012, 12:24pm)

0 276

No reply

by Roger Stover (Jun 16th 2009, 11:09am)

4 275

by hi.todd

(Jun 19th 2009, 10:27pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 275

by Wet_Boots

(Jun 19th 2006, 6:17am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 273

by hi.todd

(Jun 19th 2009, 10:29pm)

by kyle6440 (May 18th 2015, 5:22am)

1 272

by Wet_Boots

(May 18th 2015, 8:10am)

by 0303maz (Jun 12th 2012, 9:20am)

1 272

by mrfixit

(Jun 12th 2012, 9:45am)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 272

by mrfixit

(Oct 16th 2011, 2:26am)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)