You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by runningfreak (May 25th 2011, 7:32pm)

1 251

by Wet_Boots

(May 25th 2011, 8:29pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 248

by jmduke7

(Aug 16th 2006, 6:36pm)

by gerald (May 31st 2006, 5:44am)

2 247

by jmduke7

(Aug 17th 2006, 3:03pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 246

by hi.todd

(Jun 19th 2009, 10:29pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 246

by Wet_Boots

(Jun 19th 2006, 6:17am)

by rickesco (Jul 28th 2004, 8:13am)

3 246

by aquamatic

(Jul 29th 2004, 10:36am)

by ahersman (Sep 30th 2009, 1:37pm)

1 245

by ahersman

(Sep 30th 2009, 6:15pm)

by George_S (Jun 26th 2009, 7:13pm)

0 245

No reply

by keitht (Apr 11th 2006, 3:53pm)

1 244

by BSME

(Apr 12th 2006, 5:45am)

by ash13 (Jun 1st 2014, 10:06am)

4 243

by Central Irrigation

(Jun 1st 2014, 6:17pm)

Show

Statistics:

437 Threads - 1,666 Posts (average 0.35 Posts per Day)