You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 391

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 163

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by jackevln (Aug 20th 2006, 6:33am)

4 250

by mrfixit

(Aug 21st 2006, 5:12pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 199

by Wet_Boots

(Sep 15th 2007, 12:31am)

by Sue (Aug 11th 2005, 10:47am)

4 193

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 200

by mrfixit

(Jul 11th 2009, 11:59am)

by donlo (Apr 18th 2006, 3:20am)

0 109

No reply

by handan (Nov 30th 2011, 11:30pm)

2 244

by handan

(Dec 2nd 2011, 4:56am)

by osha (Aug 16th 2002, 4:34pm)

1 167

by Rays Sprinklers

(May 17th 2003, 2:53pm)

by hettiep (May 27th 2005, 5:02am)

2 275

by Jazzer K

(Sep 2nd 2005, 6:22pm)

Show

Statistics:

421 Threads - 1,568 Posts (average 0.35 Posts per Day)