You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 665

by mrfixit

(Dec 4th 2010, 1:48pm)

by Emblazed (Jul 24th 2010, 10:30am)

5 904

by Wet_Boots

(Jul 27th 2010, 10:48am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 372

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 494

by mrfixit

(Sep 10th 2011, 10:07pm)

by pillboy (Jun 8th 2011, 6:40pm)

13 5,636

by Wet_Boots

(Sep 3rd 2016, 9:12am)

by Wharfrat (May 16th 2008, 11:43am)

1 515

by mrfixit

(May 16th 2008, 5:43pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 456

by hi.todd

(Jun 19th 2009, 10:27pm)

by Mikeee (Apr 22nd 2007, 9:24am)

2 1,296

by jmduke7

(Apr 22nd 2007, 2:21pm)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 1,016

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by billinvi (Mar 30th 2007, 3:28pm)

0 256

No reply

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)