You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ianmac (Apr 25th 2011, 10:45pm)

1 853

by Wet_Boots

(Apr 26th 2011, 9:20am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 441

No reply

by Max (May 6th 2007, 8:27pm)

2 595

by Tom

(May 9th 2007, 3:29am)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 930

by GatorGuy

(Jun 12th 2012, 8:36am)

by GT6812 (Aug 28th 2015, 8:40am)

2 359

by GT6812

(Aug 31st 2015, 11:15am)

by Bert Wall (Jan 23rd 2007, 7:40am)

5 587

by Wet_Boots

(Jan 25th 2007, 12:56pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 407

by Wet_Boots

(Nov 27th 2006, 6:04am)

by MAG128 (Jun 24th 2015, 5:32pm)

3 263

by Wet_Boots

(Jun 26th 2015, 6:20am)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 495

by xpedient

(Jul 2nd 2006, 3:34pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 795

by Wet_Boots

(Oct 20th 2012, 5:11pm)

Show

Statistics:

486 Threads - 1,839 Posts (average 0.36 Posts per Day)