You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Wharfrat (May 16th 2008, 11:43am)

1 361

by mrfixit

(May 16th 2008, 5:43pm)

by jimmyburg (Nov 19th 2007, 6:27am)

1 427

by hi.todd

(Apr 6th 2008, 5:05pm)

by Dennis (Oct 15th 2007, 7:30am)

1 733

by edwildesr

(Nov 5th 2007, 7:53am)

by sanddido (Oct 11th 2007, 3:39am)

1 383

by mrfixit

(Oct 11th 2007, 2:03pm)

by purdymatthew (Aug 6th 2007, 6:05am)

1 306

by jmduke7

(Aug 7th 2007, 11:20am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 386

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by Iphis (Jul 14th 2007, 9:10am)

1 2,912

by SprinklerGuy

(Jul 14th 2007, 10:43am)

by jbalduf (May 31st 2007, 3:04pm)

1 339

by HooKooDooKu

(Jun 1st 2007, 9:13am)

by waboehly (May 1st 2007, 6:51am)

1 422

by Tom

(May 1st 2007, 3:34pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 307

by Wet_Boots

(Nov 27th 2006, 6:04am)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)