You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Rendaug (Jan 18th 2004, 12:31pm)

3 431

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 1,137

by labert

(Jan 7th 2004, 2:15pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 477

by bhungue2

(Oct 15th 2003, 8:06am)

by Chuck (Jun 29th 2003, 2:59pm)

3 717

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by rickbrum (Apr 18th 2016, 9:13am)

4 141

by hoosudaddy

(May 13th 2016, 3:13pm)

by mellow (May 31st 2015, 7:15pm)

4 307

by mrfixit

(Jun 2nd 2015, 4:08pm)

by Towelie427 (Sep 1st 2014, 7:10pm)

4 363

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 250

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by ash13 (Jun 1st 2014, 10:06am)

4 349

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 886

by mrfixit

(Jul 20th 2012, 3:06pm)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)