You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mosida (Sep 29th 2004, 9:16am)

3 451

by nestors

(Oct 31st 2004, 1:27pm)

by jbbnet (Aug 19th 2004, 5:11pm)

3 378

by SamIV

(Aug 29th 2004, 5:43am)

by rickesco (Jul 28th 2004, 8:13am)

3 394

by aquamatic

(Jul 29th 2004, 10:36am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 452

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 1,169

by labert

(Jan 7th 2004, 2:15pm)

by dzuroff (Oct 13th 2003, 7:33am)

3 489

by bhungue2

(Oct 15th 2003, 8:06am)

by Chuck (Jun 29th 2003, 2:59pm)

3 749

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by Greenweenie (Jun 21st 2010, 9:15am)

4 4,542

by Grandma Reader

(May 31st 2016, 5:33pm)

by rickbrum (Apr 18th 2016, 9:13am)

4 177

by hoosudaddy

(May 13th 2016, 3:13pm)

by mellow (May 31st 2015, 7:15pm)

4 332

by mrfixit

(Jun 2nd 2015, 4:08pm)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)