You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by veidtmeister (Jul 15th 2011, 9:03pm)

1 493

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 598

by Mitchgo

(Jul 11th 2011, 12:24am)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 376

No reply

by Val (Jun 17th 2011, 10:57pm)

4 494

by Val

(Jun 18th 2011, 7:07pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 548

by Wet_Boots

(Jun 16th 2011, 6:25am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,114

by ddeferra

(Jun 8th 2011, 6:29pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 468

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 411

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 514

by Mitchgo

(Jun 4th 2011, 3:32pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 540

by Mitchgo

(May 9th 2011, 1:04am)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)