You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by abcoker (May 9th 2014, 2:43pm)

5 418

by Wet_Boots

(May 23rd 2014, 7:04am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 279

No reply

by PerryNZ (Mar 12th 2014, 10:57pm)

5 432

by PerryNZ

(Mar 14th 2014, 12:16am)

by JT (Mar 9th 2014, 8:08pm)

1 327

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by tico (Jun 15th 2013, 8:58pm)

0 559

No reply

by Sartenose (Sep 22nd 2012, 2:31pm)

1 574

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by ksrmc (Aug 1st 2012, 3:27pm)

6 817

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by nrwe (Jul 19th 2012, 1:57pm)

4 736

by mrfixit

(Jul 20th 2012, 3:06pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 623

by s123mith

(Jul 10th 2012, 5:21am)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 2,189

by GatorGuy

(Jun 11th 2012, 8:38am)

Show

Statistics:

462 Threads - 1,748 Posts (average 0.36 Posts per Day)