You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 675

by Mitchgo

(Jul 19th 2011, 12:34am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 494

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 603

by Mitchgo

(Jul 11th 2011, 12:24am)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 377

No reply

by Val (Jun 17th 2011, 10:57pm)

4 499

by Val

(Jun 18th 2011, 7:07pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 550

by Wet_Boots

(Jun 16th 2011, 6:25am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,125

by ddeferra

(Jun 8th 2011, 6:29pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 471

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 415

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 518

by Mitchgo

(Jun 4th 2011, 3:32pm)

Show

Statistics:

506 Threads - 1,938 Posts (average 0.37 Posts per Day)