You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by shellbeach (Sep 27th 2010, 4:18pm)

2 409

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 409

by mrfixit

(Jul 10th 2009, 2:31pm)

by abhnoclue (Jun 16th 2007, 10:57am)

2 407

by abhnoclue

(Jun 17th 2007, 6:20am)

by rickesco (Jul 28th 2004, 8:13am)

3 406

by aquamatic

(Jul 29th 2004, 10:36am)

by GT6812 (Aug 28th 2015, 8:40am)

2 405

by GT6812

(Aug 31st 2015, 11:15am)

by andyl (Apr 21st 2014, 8:32pm)

3 405

by Wet_Boots

(Apr 27th 2014, 9:26am)

by mahplane (Apr 26th 2010, 5:49pm)

0 405

No reply

by peterheading (Oct 25th 2005, 5:03pm)

2 404

by Wet_Boots

(Oct 27th 2005, 2:43am)

by RodQ (Jul 11th 2010, 12:54pm)

2 403

by hi.todd

(Jul 12th 2010, 12:49pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 402

by hi.todd

(Jun 19th 2009, 10:27pm)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)