You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Kim (Jun 19th 2010, 6:45am)

1 285

by mrfixit

(Jun 19th 2010, 12:11pm)

by Bonelawr (Jul 29th 2012, 9:45am)

2 283

by Bonelawr

(Jul 29th 2012, 11:38am)

by RodQ (Jul 11th 2010, 12:54pm)

2 281

by hi.todd

(Jul 12th 2010, 12:49pm)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 279

by SteveM099

(Jun 15th 2006, 2:21pm)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 276

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by runningfreak (May 25th 2011, 7:32pm)

1 275

by Wet_Boots

(May 25th 2011, 8:29pm)

by billt (Aug 28th 2010, 10:20am)

1 275

by Wet_Boots

(Aug 28th 2010, 11:21am)

by sbradfor (Jul 20th 2003, 7:40am)

1 274

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by rickesco (Jul 28th 2004, 8:13am)

3 273

by aquamatic

(Jul 29th 2004, 10:36am)

by andyl (Apr 21st 2014, 8:32pm)

3 272

by Wet_Boots

(Apr 27th 2014, 9:26am)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)