You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Roger Stover (Jun 16th 2009, 11:09am)

4 427

by hi.todd

(Jun 19th 2009, 10:27pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 426

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 426

by hi.todd

(Jul 12th 2010, 12:49pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 426

by mrfixit

(Jul 10th 2009, 2:31pm)

by purdymatthew (Aug 6th 2007, 6:05am)

1 426

by jmduke7

(Aug 7th 2007, 11:20am)

by pete57 (Jun 19th 2007, 6:43pm)

0 426

No reply

by abhnoclue (Jun 16th 2007, 10:57am)

2 425

by abhnoclue

(Jun 17th 2007, 6:20am)

by denver9 (Aug 10th 2015, 10:47pm)

3 422

by Wet_Boots

(Aug 12th 2015, 3:44am)

by peterheading (Oct 25th 2005, 5:03pm)

2 420

by Wet_Boots

(Oct 27th 2005, 2:43am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 417

No reply

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)