You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RodQ (Jul 11th 2010, 12:54pm)

2 233

by hi.todd

(Jul 12th 2010, 12:49pm)

by abhnoclue (Jun 16th 2007, 10:57am)

2 232

by abhnoclue

(Jun 17th 2007, 6:20am)

by runningfreak (May 25th 2011, 7:32pm)

1 231

by Wet_Boots

(May 25th 2011, 8:29pm)

by Bonelawr (Jul 29th 2012, 9:45am)

2 230

by Bonelawr

(Jul 29th 2012, 11:38am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 230

by Wet_Boots

(Jun 19th 2006, 6:17am)

by keitht (Apr 11th 2006, 3:53pm)

1 230

by BSME

(Apr 12th 2006, 5:45am)

by George_S (Jun 26th 2009, 7:13pm)

0 229

No reply

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 229

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 228

by jmduke7

(Aug 16th 2006, 6:36pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 227

by hi.todd

(Jun 19th 2009, 10:29pm)

Show

Statistics:

466 Threads - 1,711 Posts (average 0.37 Posts per Day)