You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SpritzCan (Apr 21st 2012, 8:33pm)

2 168

by GatorGuy

(Apr 23rd 2012, 8:47am)

by tc1458 (Apr 13th 2005, 9:37am)

5 485

by Jazzer K

(Sep 2nd 2005, 6:17pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 162

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 172

by mugentuner

(Sep 6th 2004, 8:44am)

by lybrand (Aug 30th 2012, 3:54pm)

1 489

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by AJ Goldsmith (Jul 21st 2010, 2:48pm)

1 1,808

by Wet_Boots

(Jul 21st 2010, 7:36pm)

by Fisher (Aug 7th 2010, 5:43pm)

0 151

No reply

by Brun (Apr 29th 2008, 6:59am)

4 1,823

by hi.todd

(Nov 16th 2011, 4:49pm)

by quick11 (Oct 7th 2010, 10:53am)

3 408

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by sgb (Jun 5th 2006, 5:30pm)

0 386

No reply

Show

Statistics:

436 Threads - 1,651 Posts (average 0.36 Posts per Day)