You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,244

by ddeferra

(Jun 8th 2011, 6:29pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 551

by Mitchgo

(Jul 25th 2011, 11:12pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 660

by Mitchgo

(Jul 11th 2011, 12:24am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 2,336

by Wet_Boots

(Jul 13th 2011, 11:30am)

by opsec (Apr 1st 2012, 7:44pm)

2 834

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by BuckeyeBBB (Sep 21st 2016, 6:23pm)

1 165

by mrfixit

(Sep 22nd 2016, 2:38am)

by grey (Aug 24th 2012, 6:29pm)

1 1,834

by grey

(Aug 25th 2012, 2:19pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 944

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by fouracreDon (Mar 17th 2015, 8:09am)

2 297

by carlanw

(Apr 27th 2015, 10:52pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 1,016

by chrisratz

(Jun 29th 2012, 11:18pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)