You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by waboehly (May 1st 2007, 6:51am)

1 320

by Tom

(May 1st 2007, 3:34pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 212

by Wet_Boots

(Nov 27th 2006, 6:04am)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 723

by jmduke7

(Aug 17th 2006, 3:13pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 184

by jmduke7

(Aug 16th 2006, 6:36pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 502

by mrfixit

(Aug 7th 2006, 1:26am)

by Audit (Jun 14th 2006, 2:16am)

1 197

by xpedient

(Jun 25th 2006, 6:27pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 184

by Wet_Boots

(Jun 19th 2006, 6:17am)

by tabong (Jun 18th 2006, 5:10pm)

1 149

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 181

by SteveM099

(Jun 15th 2006, 2:21pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 168

by Wet_Boots

(Jun 8th 2006, 3:46pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)