You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JimB (Jul 30th 2011, 3:59pm)

1 304

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 488

by Mitchgo

(Jul 25th 2011, 11:12pm)

by mijd (Jul 20th 2011, 2:56pm)

2 547

by Mitchgo

(Jul 23rd 2011, 3:45am)

by irar (Jul 11th 2011, 5:27pm)

4 694

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 652

by Mitchgo

(Jul 19th 2011, 12:34am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 473

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 590

by Mitchgo

(Jul 11th 2011, 12:24am)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 369

No reply

by Val (Jun 17th 2011, 10:57pm)

4 478

by Val

(Jun 18th 2011, 7:07pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 534

by Wet_Boots

(Jun 16th 2011, 6:25am)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)