You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by gerald (May 31st 2006, 5:44am)

2 171

by jmduke7

(Aug 17th 2006, 3:03pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,066

by jmduke7

(Aug 17th 2006, 3:00pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 198

by jmduke7

(Aug 16th 2006, 6:36pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 305

by jmduke7

(Aug 16th 2006, 6:30pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 532

by mrfixit

(Aug 7th 2006, 1:26am)

by gregson (Jul 22nd 2006, 10:14am)

2 161

by nestors

(Aug 2nd 2006, 6:26pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 292

by xpedient

(Jul 2nd 2006, 3:34pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 532

No reply

by Audit (Jun 14th 2006, 2:16am)

1 218

by xpedient

(Jun 25th 2006, 6:27pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 197

by Wet_Boots

(Jun 19th 2006, 6:17am)

Show

Statistics:

436 Threads - 1,650 Posts (average 0.36 Posts per Day)