You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 705

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by bdt (Oct 17th 2011, 9:50am)

2 665

by Mitchgo

(Oct 17th 2011, 12:59pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 411

by mrfixit

(Oct 16th 2011, 2:26am)

by RT (Oct 12th 2011, 8:10pm)

1 1,096

by mrfixit

(Oct 12th 2011, 11:29pm)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 362

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 661

by mulletmac

(Oct 1st 2011, 11:26am)

by danny1949 (Sep 22nd 2011, 12:04pm)

1 420

by Wet_Boots

(Sep 22nd 2011, 5:05pm)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 844

by CRI IRR

(Sep 13th 2011, 6:34am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 492

by mrfixit

(Sep 10th 2011, 10:07pm)

by maddog (Sep 8th 2011, 5:48pm)

1 406

by grey

(Sep 9th 2011, 11:40am)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)