You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by sprinklerookie (Jun 6th 2006, 5:21am)

1 187

by jmduke7

(Aug 16th 2006, 6:36pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 187

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by Binks (Apr 10th 2013, 1:28am)

1 186

by mrfixit

(Apr 10th 2013, 3:02am)

by runningfreak (May 25th 2011, 7:32pm)

1 186

by Wet_Boots

(May 25th 2011, 8:29pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 186

by Wet_Boots

(Jul 17th 2010, 9:11am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 186

by Wet_Boots

(Jun 19th 2006, 6:17am)

by RodQ (Jul 11th 2010, 12:54pm)

2 185

by hi.todd

(Jul 12th 2010, 12:49pm)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 184

by GatorGuy

(Jul 3rd 2012, 8:00am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 184

by abhnoclue

(Jun 17th 2007, 6:20am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 183

by SteveM099

(Jun 15th 2006, 2:21pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)