You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 762

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 770

by Wet_Boots

(Aug 10th 2011, 7:51am)

by Michael (May 1st 2006, 3:41pm)

4 773

by Michael

(May 2nd 2006, 3:25am)

by mdige (Oct 31st 2011, 4:31pm)

1 784

by Wet_Boots

(Nov 1st 2011, 6:36am)

by stillc (Jul 29th 2009, 12:36pm)

2 788

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 797

by Trabecca

(Mar 18th 2013, 8:23am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 798

by Wet_Boots

(Jul 13th 2011, 11:30am)

by John199 (Aug 14th 2011, 3:57pm)

4 825

by hi.todd

(Aug 15th 2011, 7:29pm)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 828

by mrfixit

(Jun 10th 2012, 8:13pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 863

by worachj

(Oct 31st 2009, 12:47pm)

Show

Statistics:

439 Threads - 1,669 Posts (average 0.35 Posts per Day)