You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by shakeum (Sep 19th 2010, 8:50pm)

5 654

by Wet_Boots

(Sep 25th 2010, 7:21am)

by hudr0004 (Sep 12th 2011, 10:16am)

4 656

by hudr0004

(Oct 24th 2011, 8:38am)

by whitty (Apr 20th 2012, 8:09am)

10 662

by GatorGuy

(Apr 23rd 2012, 8:45am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 664

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 674

by zenavttmn

(Apr 24th 2006, 1:21pm)

by xfevv (Oct 16th 2007, 4:52am)

4 679

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by Texas Guy (May 23rd 2006, 5:48pm)

0 679

No reply

by Michael (May 1st 2006, 3:41pm)

4 680

by Michael

(May 2nd 2006, 3:25am)

by orgits (Apr 9th 2011, 5:10pm)

2 682

by Mitchgo

(Apr 10th 2011, 2:29am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 685

by ddeferra

(Jun 8th 2011, 6:29pm)

Show

Statistics:

460 Threads - 1,705 Posts (average 0.37 Posts per Day)