You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 315

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 596

by mulletmac

(Oct 1st 2011, 11:26am)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 481

by Smithwilde

(Aug 1st 2011, 8:37pm)

by stephen (May 2nd 2010, 12:11pm)

0 280

No reply

by perplexed (Sep 8th 2007, 3:35am)

4 754

by perplexed

(Sep 9th 2007, 5:20am)

by garen (Aug 8th 2012, 10:41pm)

7 895

by Wet_Boots

(Aug 24th 2012, 8:00am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 581

by Wet_Boots

(Dec 26th 2012, 8:32am)

by d leimer (Jun 14th 2009, 11:45pm)

2 557

by hi.todd

(Jun 19th 2009, 10:24pm)

by RedArt (Aug 15th 2010, 11:03am)

3 2,202

by mrfixit

(Aug 31st 2010, 2:23pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 619

by mrfixit

(Dec 4th 2010, 1:48pm)

Show

Statistics:

500 Threads - 1,910 Posts (average 0.37 Posts per Day)