You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tkbryant (Dec 26th 2005, 12:59pm)

4 1,750

by lush96

(Mar 19th 2006, 7:49pm)

by Sue (Aug 11th 2005, 10:47am)

4 225

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by Rthorn01 (Aug 4th 2005, 10:05am)

4 1,771

by RidgeRun05

(Aug 5th 2005, 8:04pm)

by cassian (Jul 31st 2005, 2:39pm)

4 361

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by avu3 (Jul 3rd 2005, 2:36pm)

4 264

by avu3

(Jul 4th 2005, 7:20pm)

by dunn (Jun 29th 2005, 3:35am)

4 370

by Wet_Boots

(Jul 4th 2005, 6:22am)

by abcoker (May 9th 2014, 2:43pm)

5 132

by Wet_Boots

(May 23rd 2014, 7:04am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 156

by PerryNZ

(Mar 14th 2014, 12:16am)

by beachdoc (May 19th 2012, 1:37pm)

5 897

by pavelow

(Oct 30th 2013, 9:51pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 399

by electrifiedmale

(Jun 30th 2013, 7:14pm)

Show

Statistics:

433 Threads - 1,636 Posts (average 0.36 Posts per Day)