You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by cassian (Jul 31st 2005, 2:39pm)

4 345

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by avu3 (Jul 3rd 2005, 2:36pm)

4 253

by avu3

(Jul 4th 2005, 7:20pm)

by dunn (Jun 29th 2005, 3:35am)

4 356

by Wet_Boots

(Jul 4th 2005, 6:22am)

by abcoker (May 9th 2014, 2:43pm)

5 110

by Wet_Boots

(May 23rd 2014, 7:04am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 141

by PerryNZ

(Mar 14th 2014, 12:16am)

by beachdoc (May 19th 2012, 1:37pm)

5 853

by pavelow

(Oct 30th 2013, 9:51pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 374

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 419

by s123mith

(Jul 10th 2012, 5:21am)

by PintoDr (Jun 28th 2012, 11:50pm)

5 570

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by Brassguy (Feb 26th 2012, 4:36pm)

5 353

by Brassguy

(Mar 8th 2012, 10:09pm)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)