You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by guy_sparky (Aug 12th 2010, 10:35am)

3 1,062

by mrfixit

(Aug 12th 2010, 5:12pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 1,096

by hi.todd

(Aug 10th 2010, 11:57am)

by Emblazed (Jul 24th 2010, 10:30am)

5 835

by Wet_Boots

(Jul 27th 2010, 10:48am)

by ssherrid (Jul 21st 2010, 12:18am)

0 621

No reply

by slugbugblue (Jul 16th 2010, 6:40am)

2 414

by Wet_Boots

(Jul 17th 2010, 9:11am)

by paul b (Jul 3rd 2010, 10:24am)

1 648

by Wet_Boots

(Jul 6th 2010, 9:21am)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,397

by PhoenixDen

(Jun 24th 2010, 11:27am)

by DRegs (May 5th 2010, 5:29pm)

1 505

by Wet_Boots

(May 6th 2010, 2:34pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 1,186

by worachj

(Oct 31st 2009, 12:47pm)

by stillc (Jul 29th 2009, 12:36pm)

2 1,011

by Wet_Boots

(Aug 4th 2009, 1:08am)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)