You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 480

by mrfixit

(Aug 7th 2006, 1:26am)

by gregson (Jul 22nd 2006, 10:14am)

2 129

by nestors

(Aug 2nd 2006, 6:26pm)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 252

by xpedient

(Jul 2nd 2006, 3:34pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 489

No reply

by Audit (Jun 14th 2006, 2:16am)

1 186

by xpedient

(Jun 25th 2006, 6:27pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 172

by Wet_Boots

(Jun 19th 2006, 6:17am)

by tabong (Jun 18th 2006, 5:10pm)

1 138

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 169

by SteveM099

(Jun 15th 2006, 2:21pm)

by jhardwick (Jun 10th 2006, 1:26pm)

0 187

No reply

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 156

by Wet_Boots

(Jun 8th 2006, 3:46pm)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)