You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Rendaug (Jan 18th 2004, 12:31pm)

3 174

by Rendaug

(Feb 8th 2004, 10:37am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 172

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 171

by jmduke7

(Aug 16th 2006, 6:36pm)

by RC (Nov 6th 2011, 7:46pm)

2 170

by Wet_Boots

(Nov 7th 2011, 7:57am)

by sbradfor (Jul 20th 2003, 7:40am)

1 170

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 169

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 168

by Wet_Boots

(Jun 19th 2006, 6:17am)

by keitht (Apr 11th 2006, 3:53pm)

1 168

by BSME

(Apr 12th 2006, 5:45am)

by billt (Aug 28th 2010, 10:20am)

1 167

by Wet_Boots

(Aug 28th 2010, 11:21am)

by kingtpt (Jul 17th 2010, 5:57pm)

5 166

by Fireguy97

(Jul 18th 2010, 11:35pm)

Show

Statistics:

427 Threads - 1,618 Posts (average 0.36 Posts per Day)