You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 177

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by Katy (Jun 1st 2012, 3:41pm)

2 177

by hi.todd

(Jun 1st 2012, 8:55pm)

by RC (Nov 6th 2011, 7:46pm)

2 176

by Wet_Boots

(Nov 7th 2011, 7:57am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 176

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by billt (Aug 28th 2010, 10:20am)

1 174

by Wet_Boots

(Aug 28th 2010, 11:21am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 174

by jmduke7

(Aug 16th 2006, 6:36pm)

by kingtpt (Jul 17th 2010, 5:57pm)

5 173

by Fireguy97

(Jul 18th 2010, 11:35pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 173

by Wet_Boots

(Jul 17th 2010, 9:11am)

by keitht (Apr 11th 2006, 3:53pm)

1 173

by BSME

(Apr 12th 2006, 5:45am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 172

by Wet_Boots

(Jun 19th 2006, 6:17am)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)