You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SteveM099 (Jun 19th 2006, 1:50am)

1 157

by Wet_Boots

(Jun 19th 2006, 6:17am)

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 156

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by RC (Nov 6th 2011, 7:46pm)

2 155

by Wet_Boots

(Nov 7th 2011, 7:57am)

by billt (Aug 28th 2010, 10:20am)

1 155

by Wet_Boots

(Aug 28th 2010, 11:21am)

by Kpierce (Apr 12th 2013, 10:36pm)

1 154

by Wet_Boots

(Apr 13th 2013, 10:46am)

by runningfreak (May 25th 2011, 7:32pm)

1 154

by Wet_Boots

(May 25th 2011, 8:29pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 154

by jmduke7

(Aug 16th 2006, 6:36pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 154

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by Katy (Jun 1st 2012, 3:41pm)

2 153

by hi.todd

(Jun 1st 2012, 8:55pm)

by sirlar (Jul 20th 2012, 2:40pm)

0 152

No reply

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)