You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,406

by mrfixit

(Jun 2nd 2010, 2:27am)

by clm716 (Aug 7th 2011, 9:58am)

1 170

by Central Irrigation

(Aug 7th 2011, 10:49am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 287

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by ksrmc (Aug 1st 2012, 3:27pm)

6 441

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Don_Mousseau (May 15th 2010, 8:44am)

1 572

by mrfixit

(May 15th 2010, 1:03pm)

by mharden5 (Jul 11th 2009, 12:45pm)

1 190

by hi.todd

(Jul 11th 2009, 9:27pm)

by Val (Jun 17th 2011, 10:57pm)

4 228

by Val

(Jun 18th 2011, 7:07pm)

by dkraska (Aug 29th 2009, 2:41pm)

4 389

by hi.todd

(Aug 30th 2009, 9:32pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 183

by jmduke7

(Aug 16th 2006, 6:36pm)

by paterjb (Jan 5th 2004, 7:46am)

5 275

by RVLI

(Jan 6th 2004, 3:16pm)

Show

Statistics:

434 Threads - 1,639 Posts (average 0.36 Posts per Day)