You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by veidtmeister (Jul 15th 2011, 9:03pm)

1 380

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 1,005

by Wet_Boots

(Jul 13th 2011, 11:30am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 838

by Mitchgo

(Jul 1st 2011, 9:20pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 477

by Wet_Boots

(Jun 16th 2011, 6:25am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 575

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 387

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 320

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 420

by Mitchgo

(Jun 4th 2011, 3:32pm)

by runningfreak (May 25th 2011, 7:32pm)

1 286

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 442

by Mitchgo

(May 9th 2011, 1:04am)

Show

Statistics:

474 Threads - 1,781 Posts (average 0.36 Posts per Day)