You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by runningfreak (May 25th 2011, 7:32pm)

1 313

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 468

by Mitchgo

(May 9th 2011, 1:04am)

by miker (Apr 30th 2011, 12:53pm)

1 518

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by jchsmiller (Apr 18th 2011, 11:47am)

1 390

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 251

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 1,097

by Mitchgo

(Apr 10th 2011, 2:29am)

by joe decoste (Mar 19th 2011, 11:56am)

1 299

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 522

by hi.todd

(Feb 27th 2011, 4:12pm)

by william62949 (Oct 10th 2010, 2:56pm)

1 400

by mrfixit

(Oct 10th 2010, 6:02pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 334

by Wet_Boots

(Sep 28th 2010, 1:11pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)