You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 300

by Wet_Boots

(Sep 15th 2007, 12:31am)

by perplexed (Sep 8th 2007, 3:35am)

4 595

by perplexed

(Sep 9th 2007, 5:20am)

by Marlene (Aug 23rd 2007, 3:11am)

4 494

by Marlene

(Aug 25th 2007, 5:42am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 282

by jmduke7

(Aug 7th 2007, 11:20am)

by lily (May 20th 2006, 9:31pm)

4 565

by daniels

(Aug 7th 2007, 11:00am)

by Jrdcpapc (Aug 1st 2007, 6:17am)

1 360

by SprinklerGuy

(Aug 2nd 2007, 12:41am)

by Iphis (Jul 14th 2007, 9:10am)

1 2,689

by SprinklerGuy

(Jul 14th 2007, 10:43am)

by MJ (Jul 8th 2007, 5:23am)

0 123

No reply

by abhnoclue (Jun 16th 2007, 10:57am)

2 249

by abhnoclue

(Jun 17th 2007, 6:20am)

by bcampy1 (Jun 15th 2007, 11:06am)

0 356

No reply

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)