You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 559

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by modetz (Jun 16th 2012, 11:23am)

1 359

by Wet_Boots

(Jun 16th 2012, 12:29pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 3,130

by Wet_Boots

(Jun 20th 2012, 10:13am)

by planersedge (Jun 20th 2012, 2:32pm)

3 398

by planersedge

(Jun 25th 2012, 7:27am)

by PintoDr (Jun 28th 2012, 11:50pm)

5 865

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 643

by chrisratz

(Jun 29th 2012, 11:18pm)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 331

by GatorGuy

(Jul 3rd 2012, 8:00am)

by m collins (Jul 5th 2012, 11:04am)

3 440

by GatorGuy

(Jul 5th 2012, 12:27pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 638

by s123mith

(Jul 10th 2012, 5:21am)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 537

by mrfixit

(Jul 14th 2012, 12:39am)

Show

Statistics:

477 Threads - 1,795 Posts (average 0.36 Posts per Day)