You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by garen (Aug 8th 2012, 10:41pm)

7 702

by Wet_Boots

(Aug 24th 2012, 8:00am)

by rspfau (Jun 9th 2011, 6:12pm)

4 704

by Mitchgo

(Jun 9th 2011, 10:08pm)

by ruchuck (May 29th 2013, 8:54am)

7 705

by mrfixit

(Jun 2nd 2013, 12:03am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 706

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Dennis (Oct 15th 2007, 7:30am)

1 716

by edwildesr

(Nov 5th 2007, 7:53am)

by RT (Oct 12th 2011, 8:10pm)

1 718

by mrfixit

(Oct 12th 2011, 11:29pm)

by ksrmc (Aug 1st 2012, 3:27pm)

6 719

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by KSknight (Aug 17th 2009, 10:53am)

1 721

by bdbengtsson

(May 21st 2010, 5:27pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 727

by Wet_Boots

(Apr 26th 2011, 9:20am)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 729

by GatorGuy

(Jun 12th 2012, 8:36am)

Show

Statistics:

469 Threads - 1,749 Posts (average 0.36 Posts per Day)