You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by slemani62 (Jul 29th 2010, 2:56pm)

1 643

by mrfixit

(Jul 29th 2010, 6:35pm)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 646

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by shakeum (Sep 19th 2010, 8:50pm)

5 646

by Wet_Boots

(Sep 25th 2010, 7:21am)

by whitty (Apr 20th 2012, 8:09am)

10 650

by GatorGuy

(Apr 23rd 2012, 8:45am)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 655

by zenavttmn

(Apr 24th 2006, 1:21pm)

by Michael (May 1st 2006, 3:41pm)

4 660

by Michael

(May 2nd 2006, 3:25am)

by orgits (Apr 9th 2011, 5:10pm)

2 665

by Mitchgo

(Apr 10th 2011, 2:29am)

by Texas Guy (May 23rd 2006, 5:48pm)

0 668

No reply

by Trabecca (Mar 13th 2013, 6:22pm)

7 670

by Trabecca

(Mar 18th 2013, 8:23am)

by xfevv (Oct 16th 2007, 4:52am)

4 672

by Cricketkiller

(Jun 7th 2008, 3:53pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)