You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 411

by mrfixit

(Mar 22nd 2014, 1:58am)

by buster99ranger (Aug 25th 2002, 7:49pm)

1 409

by micjeep1

(Aug 22nd 2004, 12:05pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 408

by Wet_Boots

(Nov 27th 2006, 6:04am)

by richard1975 (Apr 28th 2013, 7:12pm)

1 407

by Scott76

(May 2nd 2013, 2:06pm)

by chpsk8 (Mar 17th 2002, 5:25am)

1 405

by RVLI

(Mar 20th 2002, 12:31pm)

by pjmckellar (Jul 27th 2013, 8:25am)

1 402

by Central Irrigation

(Jul 27th 2013, 9:42am)

by The Professor (May 26th 2005, 9:47pm)

2 402

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by Sandart (May 25th 2006, 3:16pm)

2 401

by jlease

(May 28th 2006, 10:06am)

by pete57 (Jun 19th 2007, 6:43pm)

0 398

No reply

by Stanman (Oct 28th 2014, 10:11pm)

5 393

by Wet_Boots

(Oct 30th 2014, 5:08am)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)