You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 730

by Wet_Boots

(Oct 18th 2012, 9:14am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 352

by jmduke7

(Aug 7th 2007, 11:20am)

by George_S (Jun 26th 2009, 7:13pm)

0 298

No reply

by kxaz145 (May 1st 2009, 2:52pm)

3 1,533

by Wet_Boots

(Jun 3rd 2011, 7:49am)

by DRegs (May 5th 2010, 5:29pm)

1 435

by Wet_Boots

(May 6th 2010, 2:34pm)

by JA (May 9th 2010, 11:27am)

7 5,977

by Wet_Boots

(May 3rd 2011, 6:55am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 398

by Wet_Boots

(May 11th 2013, 5:08pm)

by dse (Jun 8th 2012, 5:58am)

2 539

by Wet_Boots

(Jun 8th 2012, 8:48am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 932

by ddeferra

(Jun 8th 2011, 6:29pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 450

by Mitchgo

(Jul 25th 2011, 11:12pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)