You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by sirlar (Jul 20th 2012, 2:40pm)

0 157

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 458

by Mitchgo

(Apr 10th 2011, 2:29am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 320

by Mitchgo

(Jul 19th 2011, 12:34am)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 277

by Mitchgo

(May 9th 2011, 1:04am)

by bbruck (Jun 20th 2009, 7:11pm)

1 299

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Kpierce (Apr 12th 2013, 10:36pm)

1 160

by Wet_Boots

(Apr 13th 2013, 10:46am)

by tinkermaniac (Aug 21st 2002, 2:36pm)

1 200

by Rays Sprinklers

(May 17th 2003, 2:51pm)

by jchsmiller (Apr 18th 2011, 11:47am)

1 242

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by Audit (Jun 14th 2006, 2:16am)

1 173

by xpedient

(Jun 25th 2006, 6:27pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 357

No reply

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)