You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 232

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by odiaz1 (May 10th 2012, 10:18am)

1 512

by Wet_Boots

(May 10th 2012, 10:26am)

by joeywfl (Jun 15th 2015, 8:34am)

1 163

by Wet_Boots

(Jun 15th 2015, 9:02am)

by ros (Mar 15th 2012, 7:40pm)

1 578

by hi.todd

(Mar 20th 2012, 9:07pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 415

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by wileyb (Mar 23rd 2015, 4:00pm)

2 673

by Wet_Boots

(Mar 24th 2015, 9:18am)

by HHicks (Jul 22nd 2011, 4:57pm)

1 845

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 411

by GatorGuy

(Jul 3rd 2012, 8:00am)

by tico (Jun 15th 2013, 8:58pm)

0 666

No reply

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 441

by mrfixit

(Apr 17th 2013, 5:56pm)

Show

Statistics:

484 Threads - 1,828 Posts (average 0.36 Posts per Day)