You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by schlaiss (Jul 1st 2010, 9:25pm)

1 205

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Kim (Jun 19th 2010, 6:45am)

1 246

by mrfixit

(Jun 19th 2010, 12:11pm)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 325

by mrfixit

(Jun 4th 2010, 7:49pm)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,521

by mrfixit

(Jun 2nd 2010, 2:27am)

by KSknight (Aug 17th 2009, 10:53am)

1 695

by bdbengtsson

(May 21st 2010, 5:27pm)

by Don_Mousseau (May 15th 2010, 8:44am)

1 655

by mrfixit

(May 15th 2010, 1:03pm)

by DRegs (May 5th 2010, 5:29pm)

1 341

by Wet_Boots

(May 6th 2010, 2:34pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 833

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 225

by ahersman

(Sep 30th 2009, 6:15pm)

by mharden5 (Jul 11th 2009, 12:45pm)

1 248

by hi.todd

(Jul 11th 2009, 9:27pm)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.36 Posts per Day)