You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by PabloCruise (May 3rd 2015, 4:28pm)

3 175

by Wet_Boots

(May 4th 2015, 11:53am)

by LT87 (May 21st 2014, 11:33am)

3 291

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 444

by Wet_Boots

(Apr 27th 2014, 9:26am)

by nightshark (Sep 9th 2013, 3:11pm)

3 1,019

by mrfixit

(Sep 9th 2013, 6:05pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 992

by Wet_Boots

(Jul 31st 2013, 10:41am)

by Pippilo (Jul 1st 2013, 9:15pm)

3 767

by mrfixit

(Jul 2nd 2013, 3:07am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 996

by mrfixit

(Jun 25th 2013, 8:32pm)

by gobris (May 14th 2013, 9:45am)

3 991

by Wet_Boots

(May 16th 2013, 8:30am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 724

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 1,336

by dgaines

(Nov 10th 2012, 4:15pm)



517 Threads - 1,975 Posts (average 0.37 Posts per Day)