You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by crashxx (Apr 28th 2012, 12:16pm)

4 754

by crashxx

(May 1st 2012, 9:15am)

by Brun (Apr 29th 2008, 6:59am)

4 1,833

by hi.todd

(Nov 16th 2011, 4:49pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 574

by hudr0004

(Oct 24th 2011, 8:38am)

by brknpcs1 (Sep 7th 2011, 10:36pm)

4 300

by Wet_Boots

(Oct 22nd 2011, 1:34pm)

by hockeyist77 (Sep 1st 2011, 6:21pm)

4 859

by hockeyist77

(Sep 7th 2011, 3:47pm)

by Jimy (Aug 30th 2011, 11:45am)

4 557

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by John199 (Aug 14th 2011, 3:57pm)

4 700

by hi.todd

(Aug 15th 2011, 7:29pm)

by irar (Jul 11th 2011, 5:27pm)

4 396

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by Val (Jun 17th 2011, 10:57pm)

4 265

by Val

(Jun 18th 2011, 7:07pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 570

by Mitchgo

(Jun 9th 2011, 10:08pm)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)