You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Drski (Jul 29th 2011, 11:50am)

5 793

by Drski

(Aug 9th 2011, 11:04am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 264

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 1,034

by Wet_Boots

(Jul 13th 2011, 11:30am)

by rspfau (Jun 9th 2011, 6:12pm)

4 806

by Mitchgo

(Jun 9th 2011, 10:08pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 345

No reply

by krantzr (Apr 30th 2011, 8:26am)

3 1,457

by mrfixit

(May 1st 2011, 11:34am)

by ianmac (Apr 25th 2011, 10:45pm)

1 790

by Wet_Boots

(Apr 26th 2011, 9:20am)

by shrpshtr (Apr 26th 2011, 12:32am)

0 469

No reply

by denm31 (Apr 4th 2011, 3:11pm)

6 1,083

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 534

by mrfixit

(Dec 4th 2010, 1:48pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)