You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 13dwf (Sep 7th 2010, 1:03pm)

4 547

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 460

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 759

by mrfixit

(Aug 12th 2010, 5:12pm)

by Emblazed (Jul 24th 2010, 10:30am)

5 603

by Wet_Boots

(Jul 27th 2010, 10:48am)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,144

by PhoenixDen

(Jun 24th 2010, 11:27am)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,582

by mrfixit

(Jun 2nd 2010, 2:27am)

by DRegs (May 5th 2010, 5:29pm)

1 369

by Wet_Boots

(May 6th 2010, 2:34pm)

by stillc (Jul 29th 2009, 12:36pm)

2 788

by Wet_Boots

(Aug 4th 2009, 1:08am)

by lydiaE (Jun 25th 2009, 11:39am)

1 447

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 337

by Wet_Boots

(Jun 26th 2009, 8:58am)

Show

Statistics:

438 Threads - 1,676 Posts (average 0.35 Posts per Day)