You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by chpsk8 (Mar 17th 2002, 5:25am)

1 296

by RVLI

(Mar 20th 2002, 12:31pm)

by pjmckellar (Jul 27th 2013, 8:25am)

1 295

by Central Irrigation

(Jul 27th 2013, 9:42am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 294

by Rendaug

(Feb 8th 2004, 10:37am)

by Sandart (May 25th 2006, 3:16pm)

2 293

by jlease

(May 28th 2006, 10:06am)

by The Professor (May 26th 2005, 9:47pm)

2 293

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by melprint (Jul 11th 2009, 9:06am)

1 289

by mrfixit

(Jul 11th 2009, 11:59am)

by Kpierce (Apr 12th 2013, 10:36pm)

1 285

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Moggie (Jun 4th 2011, 10:48am)

1 284

by Mitchgo

(Jun 5th 2011, 1:28pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 284

by Wet_Boots

(Nov 27th 2006, 6:04am)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 282

No reply

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)