You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by pjmckellar (Jul 27th 2013, 8:25am)

1 268

by Central Irrigation

(Jul 27th 2013, 9:42am)

by Moggie (Jun 4th 2011, 10:48am)

1 268

by Mitchgo

(Jun 5th 2011, 1:28pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 267

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 266

No reply

by melprint (Jul 11th 2009, 9:06am)

1 266

by mrfixit

(Jul 11th 2009, 11:59am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 261

by jmduke7

(Aug 7th 2007, 11:20am)

by Kpierce (Apr 12th 2013, 10:36pm)

1 259

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Sandart (May 25th 2006, 3:16pm)

2 259

by jlease

(May 28th 2006, 10:06am)

by glmcolo (Nov 27th 2006, 4:32am)

1 258

by Wet_Boots

(Nov 27th 2006, 6:04am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 258

by Rendaug

(Feb 8th 2004, 10:37am)

Show

Statistics:

459 Threads - 1,704 Posts (average 0.37 Posts per Day)