You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by GregM (Mar 17th 2011, 9:20am)

23 5,101

by mrfixit

(Nov 1st 2012, 9:39pm)

by rose (Sep 11th 2012, 12:24pm)

0 305

No reply

by julieblades (Jan 7th 2006, 6:27am)

6 598

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 606

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by ruchuck (May 29th 2013, 8:54am)

7 864

by mrfixit

(Jun 2nd 2013, 12:03am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 836

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by (Jun 8th 2006, 1:47pm)

1 488

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 2,461

by GatorGuy

(Jun 11th 2012, 8:38am)

by trs (Aug 4th 2015, 7:38pm)

2 195

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by redlinr (Jun 9th 2005, 3:46am)

3 924

by Jazzer K

(Sep 2nd 2005, 6:14pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)