You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by billt (Aug 28th 2010, 10:20am)

1 174

by Wet_Boots

(Aug 28th 2010, 11:21am)

by slemani62 (Jul 29th 2010, 2:56pm)

1 567

by mrfixit

(Jul 29th 2010, 6:35pm)

by AJ Goldsmith (Jul 21st 2010, 2:48pm)

1 1,670

by Wet_Boots

(Jul 21st 2010, 7:36pm)

by paul b (Jul 3rd 2010, 10:24am)

1 448

by Wet_Boots

(Jul 6th 2010, 9:21am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 141

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Kim (Jun 19th 2010, 6:45am)

1 189

by mrfixit

(Jun 19th 2010, 12:11pm)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 224

by mrfixit

(Jun 4th 2010, 7:49pm)

by henry2clue (Jun 1st 2010, 7:30pm)

1 1,345

by mrfixit

(Jun 2nd 2010, 2:27am)

by KSknight (Aug 17th 2009, 10:53am)

1 631

by bdbengtsson

(May 21st 2010, 5:27pm)

by Don_Mousseau (May 15th 2010, 8:44am)

1 557

by mrfixit

(May 15th 2010, 1:03pm)

Show

Statistics:

430 Threads - 1,625 Posts (average 0.36 Posts per Day)