You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Wharfrat (May 16th 2008, 11:43am)

1 264

by mrfixit

(May 16th 2008, 5:43pm)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,128

by Wet_Boots

(Apr 27th 2008, 11:09am)

by jimmyburg (Nov 19th 2007, 6:27am)

1 312

by hi.todd

(Apr 6th 2008, 5:05pm)

by crazydayz (Oct 17th 2007, 6:33am)

0 250

No reply

by sanddido (Oct 11th 2007, 3:39am)

1 285

by mrfixit

(Oct 11th 2007, 2:03pm)

by tmshead (Oct 1st 2007, 4:35am)

2 349

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 269

No reply

by Dan Mueller (Sep 15th 2007, 3:45am)

2 307

by Wet_Boots

(Sep 16th 2007, 7:55am)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 229

by Wet_Boots

(Sep 15th 2007, 12:31am)

by perplexed (Sep 8th 2007, 3:35am)

4 490

by perplexed

(Sep 9th 2007, 5:20am)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)