You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Grahpack (Jun 9th 2011, 7:07pm)

1 566

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by tbtech24 (Jun 9th 2011, 9:24am)

3 802

by Wet_Boots

(Jun 9th 2011, 10:09am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 879

by ddeferra

(Jun 8th 2011, 6:29pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 385

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 315

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 416

by Mitchgo

(Jun 4th 2011, 3:32pm)

by runningfreak (May 25th 2011, 7:32pm)

1 284

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 435

by Mitchgo

(May 9th 2011, 1:04am)

by miker (Apr 30th 2011, 12:53pm)

1 487

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by jchsmiller (Apr 18th 2011, 11:47am)

1 364

by Wet_Boots

(Apr 20th 2011, 12:27pm)

Show

Statistics:

465 Threads - 1,755 Posts (average 0.36 Posts per Day)