You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by India (Mar 17th 2009, 7:07am)

5 477

by HooKooDooKu

(Mar 25th 2009, 10:16pm)

by water (Oct 23rd 2008, 8:47am)

1 434

by mrfixit

(Oct 23rd 2008, 10:24am)

by edincary (Oct 3rd 2008, 8:31pm)

1 199

by mrfixit

(Oct 3rd 2008, 11:05pm)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 687

by mrfixit

(Jul 22nd 2008, 9:30pm)

by xfevv (Oct 16th 2007, 4:52am)

4 652

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by macminn (Jun 11th 2007, 5:43pm)

2 438

by mrfixit

(Jun 7th 2008, 8:13am)

by Wharfrat (May 16th 2008, 11:43am)

1 291

by mrfixit

(May 16th 2008, 5:43pm)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,329

by Wet_Boots

(Apr 27th 2008, 11:09am)

by jimmyburg (Nov 19th 2007, 6:27am)

1 347

by hi.todd

(Apr 6th 2008, 5:05pm)

by crazydayz (Oct 17th 2007, 6:33am)

0 271

No reply

Show

Statistics:

438 Threads - 1,665 Posts (average 0.36 Posts per Day)